Thursday, 16 October 2014

PD-1 and Protools 11.2.1

Bill Ritter from Electric Entertainment reported some problems when using the PD-1 with Protools !!.2.1which were not present on Protools 10 as follows

After going into record and then dropping out of record there is no output when switching to Input!

As I am in LA after the AES I went to investigate. The protools screen indicated that the PD-1 was switching the tracks to input but the only way to hear the input was to switch between playback and input on protools.

After some investigation I found that the following sequence of commands from the PD-1 will solve the problem

1) Switch to record
2) Switch to input monitor
3) Switch out of record
4) Switch back to playback monitor

A unexpected benifit of this command sequence was that  some monitor glitching on Protools was reduced.

I will add a option to the PD-1 software for this with a variable delay between steps 3) and 4), when available I will update both the PD-1 web page and this blog.

It has been over two years since the last PD-1 software update, if there are any other requests now would be a good time to make them as it will take some time to get back into thr software and test it.

I did get one request at the AES show - to switch any channel not in Record Safe to Input Monitor when stopped, I can implement this as a option at the same time.

2 comments:

Eric Wegener said...

Any updates? This issue has been a major pain for us. The "input toggle in protools" workaround allows us to hobble along, but at that point why bother using the PD-1 at all? Thanks Colin!

colinbroad said...

Avid are taking notice at last, it appears that it is only a problem on Pro Tools Native